Information ausblenden
Willkommen im Forum für alle Datenbanken! Registriere Dich kostenlos und diskutiere über DBs wie Mysql, MariaDB, Oracle, Sql-Server, Postgres, Access uvm

global net_buffer_length kann nicht dauerhaft gesetzt werden?

Dieses Thema im Forum "MySQL und MariaDB" wurde erstellt von sirnoname, 7 Dezember 2013.

  1. sirnoname

    sirnoname Neuer Benutzer

    Hallo,

    ich habe mysql auf windows installiert und die Benutzer angelegt.
    Beim Import von einer anderen komerziellen Datenbank kommt die Fehlermeldung das max_allowed_packet zu klein wäre. Bei mir wohl wegen großer Datensätze die als BLOB kommen. In diversen Foren habe ich gelesen das man mit:

    set global net_buffer_length=1000000;
    set global max_allowed_packet=1000000000;

    Einfach mal erhöhen kann.
    Zudem steht dort das man mit Einträgen in der my.ini das Dauerhaft einstellen kann.
    Leider ist bei mir nach einem Neustart vom mysqld Dienst diese Werte wieder auf den kleinen Werten.
    Hier der Inhalt der ini:


    [mysqld]
    net_buffer_length=2M
    max_allowed_packet=2M
    sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES

    Im servide selbst wird die Datei in den Parametern übergeben. Allerdings anscheinend nicht verwendet?

    Was könnte ich falsch machen?

    Grüße,
    SirNoName
     
  2. akretschmer

    akretschmer Datenbank-Guru

    Gleich 2 Fehler ;-)
    Laut http://dev.mysql.com/doc/refman/5.1/de/program-variables.html gehört das nach [mysql]. Vielleicht liegt es ja daran.
     
  3. sirnoname

    sirnoname Neuer Benutzer

    Leider nein, grad probiert.
    Ich habe auch die obigen Daten von mehreren Antworten im iNet überprüft. Es ist immer wie oben, allerdings durchgehend halt Linux mysql. Mein Linix mysql brauchte diese Angaben gar nicht, daher weis ich im Moment nicht weiter.
    Leider brauche ich es auf Windows. Der Import der Daten hat mit dem global set funktioniert, allerdings darf der Wert nicht andauernd zurückfallen nach einem Neustart.
    Ein Anderer hat geschrieben er setzt
    --max_allowed_packet=100M
    hinter mysqld. Allerdings funktioniert das mit dem Service unter Windows nicht (Parameter Änderung über Registry).

    Mir kommt es so vor als würde die ini nicht verwendet.

    Hier steht ja alles, ich hab sie im Programm Verzeichnis als ini.
    http://dev.mysql.com/doc/refman/5.1/de/option-files.html
    Der Versuch die Variante als my.cnf im c: ging auch nicht.
     
    Zuletzt bearbeitet: 7 Dezember 2013
  4. akretschmer

    akretschmer Datenbank-Guru

    Mag sein. Ich nutze weder Windows noch MySQL.

    Windows als Server-OS, nun ja. MySQL als Datenbank, nun ja. Versteh immer nicht, warum man sich das antut.
     
Die Seite wird geladen...

Diese Seite empfehlen

  1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies.
    Information ausblenden