Fehler bei Wokbench-Import

Oderdeich

Benutzer
Beiträge
9
Hallo, ich arbeite mit dem Commutity-Server 5.6.14 (Windows 7 Prof, 64 Bit) und der Workbench 5.2.47. Der Import der Daten, die ich mit der gleichen Workbench vor einigen Tagen exportiert habe, wird ständig mit folgender Fehlermeldung abgebrochen:
19:48:43 Restoring D:\BackupDaten\MySQL-Backup\Doku_Tool_Test_20131102.sql
Running: mysql.exe --defaults-extra-file="c:\users\fische~1\appdata\local\temp\tmpwupwwo.cnf" --host=localhost --user=root --port=3306 --default-character-set=utf8 --comments < "D:\\BackupDaten\\MySQL-Backup\\Doku_Tool_Test_20131102.sql"

ERROR 2006 (HY000) at line 365: MySQL server has gone away Operation failed with exitcode 1
19:48:45 Import of D:\BackupDaten\MySQL-Backup\Doku_Tool_Test_20131102.sql has finished with 1 errors


Ich habe die folgenden my.ini-Parameter in der mysqld-Section der my.ini bereits auf folgende Werte gesetzt:
max_allowed_packet = 512M
interactive_timeout = 28800
interactive_timeout = 28800
wait_timeout = 28800
interactive_timeout = 28800
wait_timeout = 28800


Das hat aber alles nichts gebracht. Das komische ist nur, dass dieser Import bereits einmal funktioniert hat. Ich bin jedenfalls mit meinem Latein am Ende. Habt ihr eine Idee?

Grüße aus Panketal von Oderdeich

 
Werbung:

akretschmer

Datenbank-Guru
Beiträge
9.028
Hallo, ich arbeite mit dem Commutity-Server 5.6.14 (Windows 7 Prof, 64 Bit) und der Workbench 5.2.47. Der Import der Daten, die ich mit der gleichen Workbench vor einigen Tagen exportiert habe, wird ständig mit folgender Fehlermeldung abgebrochen:
19:48:43 Restoring D:\BackupDaten\MySQL-Backup\Doku_Tool_Test_20131102.sql
Running: mysql.exe --defaults-extra-file="c:\users\fische~1\appdata\local\temp\tmpwupwwo.cnf" --host=localhost --user=root --port=3306 --default-character-set=utf8 --comments < "D:\\BackupDaten\\MySQL-Backup\\Doku_Tool_Test_20131102.sql"

ERROR 2006 (HY000) at line 365: MySQL server has gone away Operation failed with exitcode 1
19:48:45 Import of D:\BackupDaten\MySQL-Backup\Doku_Tool_Test_20131102.sql has finished with 1 errors



Was steht denn dort?
 

Oderdeich

Benutzer
Beiträge
9
Hallo akretschmer,
ich habe versucht an die Line 365 des 2GB-Dumps heranzukommen, weil ich dieser Stelle ein fehlerhaftes INSERT-Kommando vermutet habe. Habe es aber mit den verschiedensten Werkzeugen nicht geschafft. Ich bin jetzt auf die MySQL-Server-Version 5.1.72 (64 Bit) zurückgegangen und da läuft alles bestens. Die Lösung befriedigt mich aber nicht. Ich will nun prüfen, wie ich auf eine höhere Server-Version problemlos migrieren kann. Vielen Dank für deine Mühe und viele Grüße aus Panketal.
 

akretschmer

Datenbank-Guru
Beiträge
9.028
Werbung:

Oderdeich

Benutzer
Beiträge
9
Hallo Andreas,
vielen Dank für deine Lösungsvorschläge. Ich habe Linux nur als virtuelle Maschine (Ubuntu) installiert, ansonsten arbeite ich vorwiegend mit Windows. Zur Zeit arbeite ich mich in die App-Programmierung für das Betriebssystem Android ein.
Gruß aus Panketal von Oderdeich.
 
Oben