MariaDB RAM Zuteilung wird überschritten / OOM-Killer

felon

Neuer Benutzer
Beiträge
4
WOW!!! Danke an alle Eure tolle Hilfe!! :) selten so ein Forum erlebt, bei dem die Reaktionen so schnell gehen. Das finde ich wirklich toll! :)
Leider hänge ich grade mit dem Antworten hinterher...

@BerdB: das mit den Default-Werten hatte ich vermutet, aber verworfen. Bei einem anderen Container mit Maria10.1 hatte ich keine so großen Probleme. Aber da der RAM verbrauch in dem Container mit 10.1 auch nicht so war wie ich mir das vorgestellt hatte, habe ich die idee mit den Defaults wieder verworfen.
Danke auch für das Feedback zum Query-Cache.
Ebenfalls werde ich mich nochmal um meine Queries kümmern. Da ich an unser System ein Apache-Superset für die Auswertungen angedockt habe, könnte es also gut sein, dass meine "schlechten" Queries das auch stark beeinflussen. Ich hatte angenommen, dass der Speicher immer wieder danach freigegeben wird. Und die Geschwindigkeit bei der Ausführung war für mich in Ordnung.

@Walter: ich werde mir auf jeden fall die Connections anschauen. Diesen Wert hatte ich auch schon auf 300. Vor einer Woche hatte ich dann auf 200 reduziert. Das hat auch was gebracht.

Am Freitag bekommt unser Server ein Speicher-Upgrade damit wir temporär nicht in den OOM-Killer von PHP laufen.
(heute mit dem Dienstleister besprochen)

Am Wochenende werde ich mir dann versuchen, mit Euren Hinweisen weiter zu kommen.
Bin gespannt, was sich daraus ergibt.

Vielen Dank für Eure Tipps!!
 
Werbung:

akretschmer

Datenbank-Guru
Beiträge
9.532
ich hab nicht gesagt man könne nichts einstellen. Bei Speicher sind das 3 wichtige Parameter:

  • shared_buffers
  • work_mem
  • maintenance_work_mem

ersteres begrenzt, was global an Speicher beim Start allokiert wird. Einzelne Prozesse (je Connection wird 1 Prozess gestartet) können für z.B. Sortieroperationen dann noch extra bis zu work_mem dynamisch allokieren. maintenance_work_mem legt fest, wie viel für Dinge wie Vacuum und Indexerstellung verwendet werden darf.
 
Oben