Firewall Einstellungen für Verbindung mit MS SQL 2014

ukulele

Datenbank-Guru
Beiträge
4.702
Ich hab eine wirklich merkwürdige Situation. 2 identische VMs mit Windows 2012 R2 und MS SQL Express 2014 SP1. SQL wurde in der selben Konfiguration installiert und GPOs gelten für beide Systeme gleichermaßen.

Folgendes wurde konfiguriert:
SQL Server 2014-Konfigurations-Manager
SQL Server-Netzwerkkonfiguration \ Protokolle für 'SQLEXPRESS'
TCP/IP aktivieren
IPAll TCP-Port 1433
http://msdn.microsoft.com/en-us/library/ms345327.aspx

Server-Manager \ Computerverwaltung \ Dienste und Anwendungen \ Dienste
SQL Server-Browser Starttyp Automatisch

In der Firewall wurden folgende Ports geöffnet:
Code:
@echo =========  Ports des SQL-Servers  ===================
@echo Aktivieren von Port 1433 für die SQLServer-Standardinstanz
netsh firewall set portopening TCP 1433 "SQL Server-Standardinstanz"
@echo Aktivieren von Port 1434 für dedizierte Administratorverbindungen
netsh firewall set portopening TCP 1434 "SQL Server-Administratorverbindung"
@echo Aktivieren von Port 4022 für den konventionellen SQL Server-Service Broker 
netsh firewall set portopening TCP 4022 "SQL Server-Service Broker"
@echo Aktivieren von Port 135 für Transact-SQL-Debugger/RPC
netsh firewall set portopening TCP 135 "SQL Server-Debugger/RPC"
@echo =========  Ports für Analysedienste  ==============
@echo Aktivieren von Port 2383 für die SSAS-Standardinstanz
netsh firewall set portopening TCP 2383 "SQL Server-Analysedienste"
@echo Aktivieren von Port 2382 für den SQL Server-Browserdienst
netsh firewall set portopening TCP 2382 "SQL Server-Browser"
@echo =========  Verschiedene Anwendungen  ==============
@echo Aktivieren von Port 80 für HTTP
netsh firewall set portopening TCP 80 "HTTP"
@echo Aktivieren von Port 443 für SSL
netsh firewall set portopening TCP 443 "SSL"
@echo Aktivieren des Ports für die Schaltfläche 'Durchsuchen' des SQL Server-Browserdiensts
netsh firewall set portopening UDP 1434 "SQL Server-Browser"
@echo Zulassen von Multicast-/Broadcastantwort auf UDP (Aufzählung der Browserdienste OK)
netsh firewall set multicastbroadcastresponse ENABLE
Per GPO wird noch Datei- und Druckerfreigabe (Echoanforderungen ICMPv4 eingehend) aktiviert.

Auf die eine DB komme ich mit meinem SQL Management Studio 2008 drauf, auf die andere nicht. Auf dem funktionierenden System läuft noch ein Mailarchiv das wenige Anpassungen an der Firewall gemacht hat, daran scheint es aber nicht zu liegen. Ich habe schon wirklich viel probiert, bin aber mit der Konfiguration auf mehreren Systemen bereits erfolgreich gewesen. Nur hier läßt sich die Verbindung einfach nicht herstellen, solange die Firewall aktiv ist.
 
Werbung:

akretschmer

Datenbank-Guru
Beiträge
9.848
Ich nix Windows und M$SQL und so, aber vielleicht hilft Dir https://msdn.microsoft.com/en-us/library/cc646023.aspx weiter.

Insbesondere könnte dies von Interesse sein:

Dynamic Ports
By default, named instances (including SQL Server Express) use dynamic ports. That means that every time that the Database Engine starts, it identifies an available port and uses that port number. If the named instance is the only instance of the Database Engine installed, it will probably use TCP port 1433. If other instances of the Database Engine are installed, it will probably use a different TCP port. Because the port selected might change every time that the Database Engine is started, it is difficult to configure the firewall to enable access to the correct port number. Therefore, if a firewall is used, we recommend reconfiguring the Database Engine to use the same port number every time. This is called a fixed port or a static port. For more information, see Configure a Server to Listen on a Specific TCP Port (SQL Server Configuration Manager).

Aber, wie gesagt: ist nicht so meine Welt...
 
Werbung:

ukulele

Datenbank-Guru
Beiträge
4.702
Das sollte die Einstellung IPAll TCP-Port 1433 eigentlich fest vorgeben und es funktioniert bei der einen VM auch mit Firewall.
 
Oben